Help, my links aren’t redirecting! It just brings up a 404 error.

This is a common issue usually caused by another plugin or theme not flushing redirect rules correctly after setting up another custom post type.

To resolve the problem follow these steps:

  1. Deactivate ThirstyAffiliates, don’t worry your links are safely stored in the database.
  2. Reactivate ThirstyAffiliates
  3. Visit the Settings->Permalinks page and click save.
  4. Go back to ThirstyAffiliates->All Affiliate Links and view one of the links, it should be redirecting properly.

If it’s still happening, check if your link is set up properly and has a destination URL and that destination URL starts with http:// or https://

ThirstyAffiliates Version 2.0 to 3.0 Migration Note

When migrating from version 2.0 to 3.0 a link data migration is done to bring all the data across to the new data storage model.

In some cases, this can stall or cause some links to 404.

If you encounter this, do the following:

  • Deactivate ThirstyAffiliates
  • Reactivate ThirstyAffiliates

This should start the migration again where it left off.

in Getting StartedThirstyAffiliates (Free Version)
[data-image-id='gourmet_bg']
[data-image-id='gourmet_bg']
[data-image-id='gourmet_bg']
[data-image-id='gourmet_bg']
[data-image-id='gourmet_bg']
[data-image-id='gourmet_bg']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']
[data-image-id='gourmet']